Advance Notice of Upcoming Retirement of Platform API Legacy Versions

With the Summer ’21 release, legacy versions of the Salesforce Platform API will be retired and will no longer be supported by Salesforce.

Where: The following API versions will be retired and will no longer be supported by Salesforce:

SOAP API
7.0, 8.0, 9.0, 10.0, 11.0, 11.1, 12.0, 13.0, 14.0, 15.0, 16.0, 17.0, 18.0, 19.0, 20.0
REST API
20.0
Bulk API
16.0, 17.0, 18.0, 19.0, 20.0

This change applies to Professional (with API access enabled), Enterprise, Performance, Unlimited, and Developer editions.

When: Customers can continue to use these legacy API versions until Summer ’21 is released, at which time these legacy versions will become unavailable. When these legacy versions are retired, applications consuming these of the APIs will experience disruption. The requests will fail with an error message indicating that the requested endpoint has been deactivated.

Who: This retirement affects all API-enabled org editions and applies to both Salesforce Classic and Lightning Experience.

Why: We are focusing our development efforts on enhancing the latest API versions to improve the overall Salesforce experience when building custom functionality via applications.

How: Before the Summer ’21 release, customers must modify or upgrade their applications to function with the most current API versions available. Newer versions of our APIs offer advanced capabilities with improved security and performance.

For more information, see Knowledge Article Number 000351312.